msaudit error

Discussion of MicroSurvey CAD related issues and questions.

Moderators: Brian Sloman, Jason Poitras, James Johnston

Post Reply
Posts: 3
Joined: Fri Apr 05, 2013 12:44 pm

msaudit error

Post by ChartWell » Wed Feb 10, 2016 12:28 pm

I'm using 2016 version and upon opening a drawing I used as a template to start all drawings in the 2015 version there is a 2D draw mode error. At the command line I find
"commamd: msaudit
msaudit is not enabled while in 2d draw mode"
I cannot find where one turns 2D draw mode off. I think this is creating program crash problems upon opening other drawings also.
Thanks for your help.Richard

User avatar
Brian Sloman
Product Manager
Posts: 407
Joined: Fri Jan 07, 2005 4:42 pm
Location: Westbank, BC, Canada

Re: msaudit error

Post by Brian Sloman » Tue Feb 16, 2016 3:12 pm


The 2D Draw Mode option can be found in the System Toggles command, on the CAD Drawing Controls tab - look for the "2D Draw Mode" checkbox.

Note: The MSAudit command is intentionally disabled when 2D Draw Mode is on, because this mode intentionally introduces a mismatch between the database (which maintains the 3D z value) and the drawing (which draws the points at z=0) that would otherwise cause MSAudit to falsely detect an "error" for every point.
Brian Sloman
Development Manager
MicroSurvey Software Inc.

Post Reply